summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..87e88e4
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,14 @@
+{
+  description = "Irenes' nix flake templates";
+
+  outputs = { self }: {
+    templates = {
+      base = {
+        path = ./base;
+        description = "Uses direnv and not much else.";
+      };
+    };
+
+    defaultTemplate = self.templates.base;
+  };
+}