summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorIrene Knapp <ireneista@gmail.com>2023-10-02 00:37:13 -0700
committerIrene Knapp <ireneista@gmail.com>2023-10-02 00:37:13 -0700
commit6290842dc61dc0c747dc4e2b8724fd054dd82c0f (patch)
tree3e279105abd15829ba8d9f0c3e16edc7b7f0e067 /flake.nix
initial
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..87e88e4
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,14 @@
+{
+  description = "Irenes' nix flake templates";
+
+  outputs = { self }: {
+    templates = {
+      base = {
+        path = ./base;
+        description = "Uses direnv and not much else.";
+      };
+    };
+
+    defaultTemplate = self.templates.base;
+  };
+}