summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorIrene Knapp <ireneista@gmail.com>2021-03-11 20:15:47 -0800
committerIrene Knapp <ireneista@gmail.com>2021-03-11 20:15:47 -0800
commit86990efcf8fa63decb05f462d745b95e4992dc77 (patch)
tree46990fd1c749ccca0b6477650973d83174e5e264 /Cargo.toml
parenta159d4dd29491a1eb88163e63ceb41a903dc47b6 (diff)
refactor everything into smaller modules; move to using async-std; make the read loop async. some stuff doesn't work yet but it needed to be done and this is as clean a state as it's likely to get in, so we're committing it as a base to build on.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml6
1 files changed, 6 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index f858223..fe931da 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -8,6 +8,12 @@ edition = "2018"
 #futures = "0.3"
 lalrpop-util = "0.19"
 nix = "0.19"
+pin-project = "1.0.4"
+pin-utils = "0.1.0"
+signal-hook = "0.3.4"
+
+[dependencies.async-std]
+version = "1.7.0"
 
 [build-dependencies]
 lalrpop = { version = "0.19", features = [ "lexer" ] }