summary refs log tree commit diff
path: root/base/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'base/flake.nix')
-rw-r--r--base/flake.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/base/flake.nix b/base/flake.nix
new file mode 100644
index 0000000..c75725e
--- /dev/null
+++ b/base/flake.nix
@@ -0,0 +1,26 @@
+{
+  inputs = {
+    nixpkgs = {
+      type = "github";
+      owner = "NixOS";
+      repo = "nixpkgs";
+      ref = "nixos-23.05";
+    };
+  };
+
+  outputs = { self, nixpkgs }:
+  let supportedSystems = [ "aarch64-linux" "x86_64-linux" ];
+      forAllSystems = nixpkgs.lib.genAttrs supportedSystems;
+      nixpkgsFor = forAllSystems (system: import nixpkgs { inherit system; });
+  in {
+    devShells = forAllSystems (system: let pkgs = nixpkgsFor.${system}; in {
+      default = pkgs.mkShell {
+        nativeBuildInputs = with pkgs; [
+          cargo
+          rustc
+        ];
+      };
+    });
+  };
+}
+