summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml9
1 files changed, 3 insertions, 6 deletions
diff --git a/Cargo.toml b/Cargo.toml
index a366077..21e43da 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,12 +1,12 @@
-[lib]
+[package]
 name = "line-input"
 version = "0.1.0"
 authors = ["Irene Knapp <ireneista@gmail.com>"]
-edition = "2018"
+edition = "2021"
+publish = false
 
 [dependencies]
 #futures = "0.3"
-lalrpop-util = "0.19"
 nix = "0.19"
 pin-project = "1.0.4"
 pin-utils = "0.1.0"
@@ -14,6 +14,3 @@ pin-utils = "0.1.0"
 [dependencies.tokio]
 version = "1.6.1"
 features = [ "full" ]
-
-[build-dependencies]
-lalrpop = { version = "0.19", features = [ "lexer" ] }