summary refs log tree commit diff
path: root/shell.nix
diff options
context:
space:
mode:
authorIrene Knapp <ireneista@gmail.com>2020-09-01 20:25:26 -0700
committerIrene Knapp <ireneista@gmail.com>2020-09-01 20:25:26 -0700
commit0c8e06d588038ae6e24d1898bd33b3ee5a938640 (patch)
tree74833939e37908366fe2cb71d639dbe641e054a6 /shell.nix
Initial.
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..d675097
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,17 @@
+let
+  pkgs = import <nixpkgs> {};
+  crate2nix-src = pkgs.fetchFromGitHub {
+    owner = "kolloch";
+    repo = "crate2nix";
+    rev = "0.8.0";
+    sha256 = "17mmf5sqn0fmpqrf52icq92nf1sy5yacwx9vafk43piaq433ba56";
+  };
+  crate2nix = pkgs.callPackage (import crate2nix-src) { };
+in
+pkgs.mkShell {
+  buildInputs = with pkgs; [
+    cargo
+    crate2nix
+    rustc
+  ];
+}