summary refs log tree commit diff
path: root/shell.nix
diff options
context:
space:
mode:
authorIrene Knapp <ireneista@gmail.com>2020-11-30 14:59:06 -0800
committerIrene Knapp <ireneista@gmail.com>2020-11-30 14:59:06 -0800
commit94f1a4f1245f69359aa6b1136742a0bbac3ae249 (patch)
tree9fba7602129005ecaa7ca83263cf3201dbf6eff2 /shell.nix
Add a license
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..0860ad5
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,20 @@
+let
+  pkgs = import <nixpkgs> {};
+  crate2nix-src = pkgs.fetchFromGitHub {
+    owner = "kolloch";
+    repo = "crate2nix";
+    rev = "0.8.0";
+    sha256 = "17mmf5sqn0fmpqrf52icq92nf1sy5yacwx9vafk43piaq433ba56";
+  };
+  crate2nix = pkgs.callPackage (import crate2nix-src) { };
+in
+pkgs.mkShell {
+  buildInputs = with pkgs; [
+    cargo
+    cmake
+    crate2nix
+    go
+    pkgconfig
+    rustc
+  ];
+}